N26 Open Banking - Degraded Performance in Payment initiation Services

Incident Report for Tink providers Germany

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted May 08, 2025 - 17:58 UTC

Investigating

We are currently investigating an issue with N26.
Posted Apr 17, 2025 - 18:14 UTC
This incident affected: N26.