DKB - Major ourage

Incident Report for Tink providers Germany

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted Aug 30, 2025 - 10:53 UTC

Investigating

We are currently investigating an issue with DKB.
Posted Aug 29, 2025 - 05:09 UTC
This incident affected: DKB.