VR Banks - Degraded performance

Incident Report for Tink providers Germany

Resolved

This incident has been resolved.
Posted Dec 11, 2025 - 12:29 CET

Identified

We have identified the issue and we will update when a significant change to the situation occurs.
- Affected users: 70%
- Affected flow: Manual authentication | On-demand Refresh | Background Refresh | Payment Initiation
- Start Time: 11.12.2025 8:07 CET
- Bank side error: Certificate invalid
Posted Dec 11, 2025 - 08:52 CET