Deutsche Bank, Norisbank and Postbank - Major Outage

Incident Report for Tink providers Germany

Update

The severity of this incident has increased.
Posted Jul 18, 2025 - 19:31 UTC

Investigating

We are currently investigating an issue with Deutsche Bank, Norisbank and Postbank that affects Payment Initiation.
Posted Jul 18, 2025 - 18:45 UTC
This incident affects: Deutsche Bank, Norisbank, and Postbank.