Deutsche Bank Outage

Incident Report for Tink providers Germany

Resolved

This incident has been resolved.
Posted Nov 11, 2025 - 10:49 CET

Investigating

Investigating - Tink automatic monitoring service has detected a service outage.

- Affected flow(s): auto refresh
- Affected users: 79%
- Start time: 2025-11-11 10:14 CEST
- Bank side error: Error in auto refresh.
Posted Nov 11, 2025 - 10:34 CET
This incident affected: Deutsche Bank.