Targobank Open Banking - Major outage affecting Account Information and Payment Initiation
Incident Report for Tink providers Germany
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Jan 15, 2025 - 14:22 UTC
Identified
We have identified the issue and we will update when a significant change to the situation occurs.
Posted Jan 15, 2025 - 13:38 UTC
This incident affected: Targobank.