ING Open banking - Degraded performance
Incident Report for Tink providers Germany
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Apr 04, 2024 - 10:34 UTC
Investigating
We are currently investigating an issue with ING.
Posted Mar 30, 2024 - 11:17 UTC
This incident affected: ING.