Deutschebank - Major outage
Incident Report for Tink providers Germany
Resolved
This incident has been resolved.
Posted Dec 07, 2022 - 08:22 UTC
Identified
We have identified the issue and are in contact with Deutschebank for further information.
We will update when a significant change to the situation occurs.
Posted Dec 06, 2022 - 14:13 UTC
This incident affected: Deutsche Bank.