Postbank - Degraded Performance

Incident Report for Tink providers Germany

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted Sep 06, 2026 - 08:41 CEST

Investigating

We are currently investigating an issue with Postbank.
Posted Sep 05, 2026 - 20:52 CEST
This incident affected: Postbank.