Commerzbank - Major outage

Incident Report for Tink providers Germany

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted Mar 20, 2025 - 14:56 UTC

Investigating

We are currently investigating an issue with Commerzbank.
Posted Mar 20, 2025 - 10:43 UTC
This incident affected: Commerzbank.