Deutsche Bank Open Banking - Aggregation Service - Degraded Performance

Incident Report for Tink providers Germany

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted May 12, 2025 - 10:34 UTC

Identified

We are currently investigating an issue with Deutsche Bank. Around 50% of all traffic is affected. An update will be posted when a significant change to the situation occurs.
Posted May 12, 2025 - 10:20 UTC
This incident affected: Deutsche Bank.