Targobank Open Banking - Partial Outage

Incident Report for Tink providers Germany

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted May 14, 2025 - 05:49 UTC

Identified

We have identified the issue and we will update when a significant change to the situation occurs.
Posted May 13, 2025 - 22:57 UTC
This incident affected: Targobank.