Deutsche Bank and Norisbank - Open Banking - Degraded performance affecting Account Information.

Incident Report for Tink providers Germany

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted Mar 24, 2025 - 08:13 UTC

Identified

We have identified the issue and we will update when a significant change to the situation occurs.
Posted Mar 23, 2025 - 10:05 UTC
This incident affected: Deutsche Bank and Norisbank.