Deutschebank - Major outage

Incident Report for Tink providers Germany

Resolved

This issue has been resolved. We apologize for the inconvenience.
Posted Sep 03, 2025 - 06:55 UTC

Investigating

We are currently investigating an issue with Deutschebank.
Posted Sep 02, 2025 - 09:33 UTC
This incident affected: Deutsche Bank.