Targo Bank Open Banking Partial Outage
Incident Report for Tink providers Germany
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Apr 04, 2024 - 10:34 UTC
Identified
We have identified the issue and are in contact with Targo Bank for further information.
We will update when a significant change to the situation occurs.
Posted Apr 02, 2024 - 08:46 UTC
Investigating
We are currently investigating an issue with Targo Bank.
Posted Apr 02, 2024 - 08:46 UTC
This incident affected: Targobank.