Targobank PIS Outage

Incident Report for Tink providers Germany

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 14:26 CET

Investigating

Investigating - Tink automatic monitoring service has detected a service outage.

- Affected users: 100%
- Affected flow: Payment Initiation flow
- Start Time: 18/11/2025 9:37
- Bank side error: Internal Server Error
- Provider name: de-targobank-ob
Posted Nov 18, 2025 - 09:43 CET
This incident affected: Targobank.