Postbank Open Banking - Major outage affecting Payment Initiation

Incident Report for Tink providers Germany

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted May 14, 2025 - 16:54 UTC

Identified

We have identified the issue and we will update when a significant change to the situation occurs.
Posted May 14, 2025 - 16:44 UTC
This incident affected: Postbank.